Advanced Fraud Solutions - TrueChecks Unplanned Outage
Incident Report for Advanced Fraud Solutions
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 18:39 EDT
Identified
The root cause has been identified as an unforeseen scenario within AFS' contribution process. This scenario triggered a normally off-hours process to occur during the peak processing window. It also resulted in an inordinately large amount of transactions processing. This caused system resource demand beyond capacity. Research is being finalized in order to define mitigation efforts which will be implemented, based on urgency.

Thank you for your patience and understanding as the full resolution of this outage continues.
Posted Sep 24, 2021 - 15:05 EDT
Update
Systems returned to normal operations at approximately 12:35 PM eastern. Root cause analysis is underway.
Posted Sep 24, 2021 - 13:18 EDT
Investigating
The Advanced Fraud Solutions team is aware of a system issue resulting in queries timing out. We are currently investigating this issue as we speak. We are sorry for the troubles today and updates will be provided as soon as they are available.
Posted Sep 24, 2021 - 12:28 EDT
This incident affected: AFS Fraud Mitigation Portal, TrueChecks API, TrueChecks Batch, and 3rd party information services.