Advanced Fraud Solutions - TrueChecks Unplanned Outage
Incident Report for Advanced Fraud Solutions
Resolved
The root cause has been identified as an unforeseen scenario were an off-hours process triggered during the peak processing window. This resulted in an inordinately large amount of transactions processing, causing system resource demand beyond capacity. Mitigation items have been identified and will be implemented, based on urgency. Preventative process has been put in place and this incident is now resolved. Thank you for bearing with us as this incident was addressed.
Posted Oct 26, 2021 - 14:58 EDT
Identified
Systems are currently stable and have returned to normal processing speeds. Investigation into cause is still ongoing. We are sorry for the troubles today and further updates will be provided as soon as they are available.
Posted Oct 26, 2021 - 14:12 EDT
Update
We are continuing to investigate this issue.
Posted Oct 26, 2021 - 13:34 EDT
Investigating
The Advanced Fraud Solutions team is aware of a system issue most likely resulting in queries timing out. We are currently investigating this issue as we speak. We are sorry for the troubles today and updates will be provided as soon as they are available.
Posted Oct 26, 2021 - 13:33 EDT
This incident affected: AFS Fraud Mitigation Portal, TrueChecks API, TrueChecks Batch, and 3rd party information services.