TrueChecks Login Incident
Incident Report for Advanced Fraud Solutions
Resolved
The TrueChecks Login Incident has been resolved. Thank you for bearing with us as we got this fixed.
Posted Nov 23, 2020 - 12:52 EST
Monitoring
A fix has been implemented into production and we are monitoring the TrueChecks logins to ensure successful logins.
Posted Nov 23, 2020 - 11:58 EST
Identified
We are aware that some TrueChecks users trying to log into the Portal are receiving an error message. Our team is looking into this incident now and will continue to update our customers has soon as a fix is in place.

Error: "Cannot access this client from your location. Please have your TrueChecks Administrator contact Support at 1-866-663-4709 Option 2"

We are sorry for the troubles this morning.
Posted Nov 23, 2020 - 08:35 EST
This incident affected: AFS Fraud Mitigation Portal.