Treasury Site Unavailable
Incident Report for Advanced Fraud Solutions
Resolved
This incident is now resolved. The secondary issue's root cause was a version mismatch (known issue), within AFS' third-party framework. This was addressed fully last night and the new Treasury solution is now stable.

Thank you for your business and support.
Posted Jan 07, 2021 - 10:01 EST
Update
While the release did allow AFS to once again interact with The Treasury, earlier this morning an issue with calls from the new solution was discovered. An initial fix is in place with monitoring continuing. Treasury queries are again fully operational.

Further updates will be relayed, as they are available.

AFS regrets any inconvenience and appreciates your patience as this is addressed.
Posted Jan 06, 2021 - 12:03 EST
Update
The release completed successfully and monitoring is continuing to ensure full resolution.
Posted Jan 05, 2021 - 23:13 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 05, 2021 - 15:02 EST
Monitoring
It has come to AFS' attention that Treasury queries are resulting in the response "Treasury Site Unavailable - Please refer to your normal check cashing policies". This is due to The Treasury prematurely decommissioning their TCVA solution. To address this, AFS will be performing an early release of its new solution for polling against Treasury data, via The Treasury's API interface.

The release is scheduled to begin tonight at 10 PM eastern and should not impact connectivity or processing.

Only items queried against Treasury data are currently impacted. All other 3rd party information services are operational.

Further updates will be relayed, as they are available.

AFS regrets any inconvenience and appreciates your patience as this is addressed.
Posted Jan 05, 2021 - 15:01 EST
This incident affected: 3rd party information services.