TrueACH Issues

Incident Report for Advanced Fraud Solutions

Identified

AFS engineers have identified the issue. We are currently awaiting final QA and approval to push the fix to the production environment. Once we do so, we will re-process any files affected by the problem.

We'll provide our next update by 4:30 PM ET at the latest.

Thank you for your patience and your partnership with Advanced Fraud Solutions.
Posted Mar 23, 2026 - 14:34 EDT

Investigating

TrueACH is currently experiencing intermittent issues with file processing times and some AOA results. Our engineering team is reviewing this as their top priority, and we will provide another update by 2:30 PM ET / 11:30 AM PT.
Posted Mar 23, 2026 - 12:18 EDT
This incident affects: TrueACH.