TrueChecks issues

Incident Report for Advanced Fraud Solutions

Resolved

AFS engineers have been monitoring the system and determined the issue is fully resolved. TrueChecks is running normally for all users. If you are still experiencing issues, please reach out to support@advancedfraudsolutions.com right away and we'll be sure to investigate.

Thank you again for your partnership with Advanced Fraud Solutions.
Posted Feb 18, 2026 - 09:16 EST

Monitoring

TrueChecks searches are working as expected again. We are continuing to monitor the system and will provide another update shortly.

Thank you for your partnership and your patience as we work to ensure TrueChecks is running smoothly for everyone.
Posted Feb 18, 2026 - 08:47 EST

Investigating

TrueChecks is showing error messages for some customers when searching checks. Our Engineering team is investigating as their top priority and we expect to have an update very shortly. We apologize for the inconvenience and will have the system back to normal ASAP.
Posted Feb 18, 2026 - 08:34 EST
This incident affected: AFS Fraud Mitigation Portal, TrueChecks API, and TrueChecks Batch.